No head light and hi light

The bit everyone hates, electrical problems. Hope you find your fix here. Posting restricted to registered users.
Post Reply
NSRichard
Posts: 36
Joined: Fri Apr 02, 2010 9:10 pm
AntiSpam: No

No head light and hi light

Post by NSRichard »

Hi,

Who can help me solve this prob:
My normal head light (only small light) does not work, allso "light hi/ lo" does nothing. If i use pass knob, then that's the only way the High light works.
Fuses are ok (checked all 10 A)

Thanks allready,

Richard

I'd like to use the ns for the TT night ride at Assen, but this doesn't light up...

Mark
Posts: 1360
Joined: Thu Oct 25, 2001 1:01 am
Location: Up Norf

Re: No head light and hi light

Post by Mark »

Sounds like a corroded connection or switch.

Check all multi plug connectors, and take the switch apart to check for corrosion. A quick blast with contact cleaner and a bit of a rub with some fine wet & dry will probably cure it.
If it ain't broke, fix it 'til it is.

Alastair
Posts: 1808
Joined: Sat May 25, 2002 1:01 am
Location: Glossop U.K.
Contact:

Re: No head light and hi light

Post by Alastair »

Mark wrote:Sounds like a corroded connection or switch.

Check all multi plug connectors, and take the switch apart to check for corrosion. A quick blast with contact cleaner and a bit of a rub with some fine wet & dry will probably cure it.
Better than wet and dry, use Brasso as it is less aggressive. I cleaned up my ignition switch with nothing more than thinners.

NSRichard
Posts: 36
Joined: Fri Apr 02, 2010 9:10 pm
AntiSpam: No

Re: No head light and hi light

Post by NSRichard »

Thanks for the reply,

Tried to open up the block where the switches are in, didn't come that far, too little time before Friday and too scared to brake a part.....
Is there a discription on the net with piccies how to do it?
Want to change the throttle tube and grips, want to do it at the same time.

Regards,

Richard

Post Reply